1

I am trying to mount S3 bucket on my on-premises CentOS-6 server using s3fs as below:

[roots@myhost ~]# s3fs bucket-name /mnt/s3mnt -o  uid=1001,gid=1001,allow_other,umask=022,iam_role=iam-role,use_cache=/tmp 

This gives error :

s3fs: unable to access MOUNTPOINT /mnt/s3mnt: Transport endpoint is not connected
debug : 
    set_moutpoint_attribute(3293): PROC(uid=0, gid=0) - MountPoint(uid=0, gid=0, mode=40777)
s3fs_init(2597): init
s3fs_check_service(2896): check services.
RequestPerform(1524): ### CURLE_OPERATION_TIMEDOUT
    RequestPerform(1617): ### retrying...
    RemakeHandle(1288): Retry request. [type=-1][url=http://169.254.169.254/latest/meta-data/iam/security-credentials/iam-role][path=]
    RequestPerform(1620): Failed to reset handle and internal data for retrying.
s3fs: Failed to check IAM role name(iam-role).

Please let me know if somebody did it successfully. Tried with endpoint parameter and URL parameter but it says:

fuse: unknown option `endpoint=ap-northeast-1'

Any suggestion is highly appreciated. Thank you.

1

Have you got AWS credentials configured on that machine?

~ $ aws configure

And then verify with:

~ $ aws sts get-caller-identity

Hope that helps :)

1
  • yes, this point already checked. looks like there is some issue with the older version of fuse, without iamrole parameter it is working fine. – Abhilash Mishra Jan 9 '20 at 0:29
0

Following worked for me - /usr/bin/s3fs my-bucket /my-mount/ -o uid=500,gid=501,iam_role=MyRole,use_cache=/tmp,endpoint=ap-south-1,url=https://s3.amazonaws.com

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.