0

In the YAML file defining our ADO build pipeline we have the following section

- bash: |
    pip install pylint
    find preprocessing/ subtyping/ visualisations/ -name '*.py' | grep -v hmm | grep -v /test_ | sort | xargs pylint
  displayName: 'Run linter'

At some point in the last week this stopped working. It still works on an ubuntu-latest hosted agent, but on Windows (either windows-latest or vs2017-win2016) it now fails with the message

FIND: Parameter format not correct

We have not changed anything, but our build process now fails.

  • What has changed to cause this failure?
  • Why does it only fail on Windows?
  • How might I diagnose the problem?
  • Is there anything wrong with our call to bash's 'find' command?
2

Find is a command in Windows that does very different thing to find in a posix shell.

And that would be the error you would get if you ran the Windows find (usually Windows find is located at C:\Windows\System32\find.exe

| improve this answer | |
1

Your PATH may have somehow changed and you're now hitting the Windows find instead of the *nix-compatible one.

Try specifying the full path, i.e. /usr/bin/find (that's what I see on my windows bash shell when I check with which find) instead of just find in your build process command.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.