25

My organisation uses Azure DevOps and we want to use git as our repo.

But, Azure projects seem to only allow one git repo per project.

This is bizarre to me! Projects and repos are usually separate. One project may involve development on several tools, and a tool may be used by several projects.

How can I get projects to engage with multiple git repos?

3 Answers 3

29

Following works for me:

  • Click on your Project and then [Repos] in the left hand menu.
  • Along the top, you'll see the bread-crumbs: Organization / Project / Repos / Files / {NameOfCurrentRepo}
  • Click the down arrow next to that and you'll see the option to add a new Repository

If that's not available, then it must be a permissions setting that I'm not aware of.

3
  • 1
    This is the correct answer - it's a horrible interface, but thanks for the assist.
    – JohnFF
    Feb 24, 2020 at 17:14
  • I cannot see this option and I should have ALL permissions. I'm the only user on the AAD, I created this project, (original) repo and everything involved with it. How can I not have permission to add a repo to it?!
    – ataraxia
    Aug 8, 2020 at 20:14
  • As of late 2022 this still seems to be the correct answer. Not at all obvious.
    – KeithL
    Sep 20, 2022 at 16:05
2

As an alternative to DrGriff's answer..

  • Go to the [Project Settings] for your project and select [Repos] / [Repositories] on the left-hand side
  • There should be a "Create" button on the top right (below your profile button)

If you don't see the "Create" button your user almost certainly does not have the permission to create repositories for this project.

Looking at ataraxia's comment, I had the same issue. I was both a project and collection administrator but could not create a new repository. The reason being that I had explicitly set "Deny" on the "Create repository" permission for "Contributors". An explicit Deny on one of the groups you belong to seems to override your Allow privileges. So please go over your group member privileges, perhaps that solves your problem?

1
  • In my case, this was the issue. As I was still new to Azure DevOps, I just assumed that since I was an admin of the project that gave me rights for everything. Turns out, looking at Nolte's answer, there was some more setup I had to do but never did: under Project Settings->General->Permissions I realized that I hadn't touched the settings for ANY of groups listed and most of them had their values set to "Not Set". Nolte's solution not only fixed the OP's issue (and mine) but made me realize that there were still more permissions to be set up in general.
    – Architekt
    Feb 15, 2023 at 15:07
2

If you have alread added one repository to your project then you should do the following:

  1. On left hand side panel click on repos
  2. On the top panel you will see organization-name/project name/Repos/Files/current repository - click on current repository which has a git icon next to it and a down-arrow to its right
  3. Press on Import repository
  4. Enter the details of your repository on the pop-up pannel

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.