Kubernetes version: latest Installation method: kubeadm Host OS: debian9 container runtime: containerd

Kubelet fails when starting and after inspecting the logs using journalctl -xeu kubelet i see that it tries to connect to the docker.sock socket instead of containerd.sock. I tried running kubeadm --config=config.yaml using this config file

apiVersion: kubeadm.k8s.io/v1beta1
kind: InitConfiguration
        criSocket: "unix:///var/run/containerd/containerd.sock"

I have also tried running the kubeadm with the container runtime 85 argument, also doesn’t work. any other ideas are appreciated and thanks


In kubeadm docs

--cri-socket stringPath to the CRI socket to connect. If empty kubeadm will try to auto-detect this value; use this option only if you have more than one CRI installed or if you have non-standard CRI socket.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.