0

I have the next ingress (output of "kubectl get ingress")

NAME   HOSTS   ADDRESS          PORTS   AGE
main   *       192.168.39.190   80      46m

But when I try to visit that IP address in chrome I get

Cannot access the website. Check if there's a write error in name.local
DNS_PROBE_FINISHED_NXDOMAIN

Any idea why? Everything is green on the dashboard, there are errors.

1
  • Requests that sent directly to an IP address should not trigger a DNS probe, so you are probably using a domain name and it is name.local according to your error message. I am also having a hard time when resolving .local domains with chrome recently. It's probably because of secure dns configuration With this config, chrome bypasses your system resolver and sends queries to 3rd party over https. You may want to try to turn off "secure dns" in your google chrome settings. – yozel Feb 22 at 20:56
1

There are two main reasons for this issue to happen:

  1. Your dns are not exposed.
  2. Your code is redirecting to a https address (and since you are working in your local machine, most likely you don't have a secure certificate)

CASE 1 - Exposing DNS

On linux you can solve it like:

  • minikube ip

  • vim /etc/hosts

  • Add the ip from the first step and the hostname you want to expose, and save the file.

    # For example
    192.168.39.70   elasticsearch-es-http
    

No need to restart any service, it should work just like that. Add all the hostnames you need.

CASE 2 - HTTPS on minikube

If your problem is 2, then you have to find a way for you application to not use HTTPS while you are using minikube.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.