0

I am installing opensource kubeadm in google cloud platform using k8s configuration files. As part of the installation, i updated the cloudprovider values as gce in initconfiguration, apiserver and conroller manager. I created cloud-config file with GCE project name and updated this path in kubelet configuration file.

After running the job, all the kubernetes node are joined in the cluster. But the master nodes are tainted as "node.kubernetes.io/network-unavailable".

If i change the cloud provider as "external", all the master nodes came up and tainted properly.

Please let me know, how to pass the cloud provider value as gcp?

1
  • This issue was resolved, i found out the that culprit in my code is flannel version. Initially i used the flannel version as :"quay.io/coreos/flannel:v0.11.0-amd64" After changing the flannel flag to : "quay.io/coreos/flannel:v0.13.1-rc2" – TechHunter Feb 10 at 2:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.