0

I'm attempting to enable the AppEngine service via Terraform but I'm getting an error:

Error: Error creating App Engine application: googleapi: Error 403: App Engine Admin API has not been used in project <redacted> before or it is disabled. Enable it by visiting https://console.developers.google.com/apis/api/appengine.googleapis.com/overview?project=<redacted> then retry. If you enabled this API recently, wait a few minutes for the action to propagate to our systems and retry., accessNotConfigured

As far as I know all that should be required to enable the service/API is:

// Enable AppEngine API - required to automagically create datastore
resource "google_project_service" "appengine_api" {
  project = var.project
  service = "appengine.googleapis.com"

  disable_dependent_services = true
}
3
  • 1
    "If you enabled this API recently, wait a few minutes for the action to propagate to our systems and retry., accessNotConfigured" What does it do if you retry a bit later ? (a null_resource just to wait a few minutes before the rest of your plan could be a solution if it works after a retry) – Tensibai Feb 19 at 23:39
  • @Tensibai, not a timing issue in this case. The API was enabled successfully but all following attempts to create the appengine app fail with that error. – Jake Nelson Feb 21 at 10:44
  • Yes that's what the message says, the API is created but you may need to way a bit to use it. – Tensibai Feb 21 at 11:35
0

The terraform service account was located in a separate project and the API needed to be enabled for appengine in the account the Terraform service account runs in even though it was creating a resource in an another project.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.