0

I've a stranger situation using EKS, follows my environment:

EKS - kubernetes version v1.18.9-eks-d1db3c Ingress - Traefik:v2.3, and we have 2 load balancers

  • internal - load balancer
  • external - load balancer

Both internal and external load balancer are configured with SSL, but in external load balancer sometimes is losing SSL configuration, and i've go there and attach again manually, i'm try to reach the root cause.

This error is intermittent, it happens at least once a month and we are bother about it

In CloudTrail service i've found the error code InvalidConfigurationRequestException, follows the event when the problem happens, the output is here:

{
    "eventVersion": "1.08",
    "userIdentity": {
        "type": "AssumedRole",
        "principalId": "XXXXXXXXXXXXXXXXX",
        "arn": "arn:aws:sts::XXXXXXXXXXX:assumed-role/homolog-eks/1613546755047123266",
        "accountId": "XXXXXXXXXXX",
        "accessKeyId": "ASIA5MJJJI36YRUQLVRX",
        "sessionContext": {
            "sessionIssuer": {
                "type": "Role",
                "principalId": "AROAICYIAFD3HEVDXEZZI",
                "arn": "arn:aws:iam::XXXXXXXXXXX:role/homolog-eks",
                "accountId": "XXXXXXXXXXX",
                "userName": "homolog-eks"
            },
            "webIdFederationData": {},
            "attributes": {
                "mfaAuthenticated": "false",
                "creationDate": "2021-02-17T11:41:36Z"
            }
        },
        "invokedBy": "eks.amazonaws.com"
    },
    "eventTime": "2021-02-17T11:46:37Z",
    "eventSource": "elasticloadbalancing.amazonaws.com",
    "eventName": "DetachLoadBalancerFromSubnets",
    "awsRegion": "us-east-1",
    "sourceIPAddress": "eks.amazonaws.com",
    "userAgent": "eks.amazonaws.com",
    "errorCode": "InvalidConfigurationRequestException",
    "errorMessage": "Requested configuration change for LoadBalancer \"a6f763f13f68c11e8801c12b371cef55\" is invalid because you attempted to detach all the subnets for this LoadBalancer and a LoadBalancer cannot be attached to zero subnets in VPC.",
    "requestParameters": {
        "subnets": [
            "subnet-00f5def356ae18cf9",
            "subnet-0533cea127b579ab6"
        ],
        "loadBalancerName": "a6f763f13f68c11e8801c12b371cef55"
    },
    "responseElements": null,
    "requestID": "c3a76b67-4512-4603-a321-03ff0ae6042f",
    "eventID": "cf23d8ae-c4d1-4621-a0ee-b565df524918",
    "readOnly": false,
    "eventType": "AwsApiCall",
    "apiVersion": "2012-06-01",
    "managementEvent": true,
    "eventCategory": "Management",
    "recipientAccountId": "XXXXXXXXXXX"
}

Tag Amazon VPC Subnets for EKS is configured: https://aws.amazon.com/premiumsupport/knowledge-center/eks-vpc-subnet-discovery

Please, let me know if you have advice to give me

Regards,

1
  • Mey the problem is here: " "errorMessage": "Requested configuration change for LoadBalancer \"a6f763f13f68c11e8801c12b371cef55\" is invalid because you attempted to detach all the subnets for this LoadBalancer and a LoadBalancer cannot be attached to zero subnets in VPC."," – Weyder Ferreira Mar 2 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.