0

I am trying to configure loki-stack using a helm chart to my k8s cluster.

Since my k8s cluster uses CRIO and not docker (which is common nowdays) I need to change the pipeline_stages: config map to use cri: {} instead of docker: {} to parse the logs properly.

How do I change the helm chart so that cri: {} is used by default instead of docker: {} in all the pipeline_stages:? many thanks.

3
  • Doesn't the most recent version of that chart already use cri by default? github.com/grafana/helm-charts/blob/… – Briansbum Mar 15 at 10:45
  • for some reason when i deploy the loki-stack helm chart, it deploys it with docker... I did actually try in my requirements.yaml to require the latest version by doing version: "^3.5.0" for promtail and it keeps deploying docker :( – user2324712 Mar 15 at 19:51
  • @Briansbum, per your comment, i've attempted to deploy loki-stack in a katacoda k8s cluster independently of my own cluster and I can confirm that it used docker: {} instead of cri: {} as well. I think that the helm chart has a snippet using cri but is not actually using it and something needs to be done to make it use cri: {} instead of docker: {} – user2324712 Mar 15 at 20:05
1

Managed to solve this by changing the values.yaml in the loki-stack helm chart to the following:

promtail:
  enabled: true
  pipelineStages:
  - cri: {}

Enjoy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.