0

I have a cluster installed on Openshift and used the Cluster Logging Operator and Elasticsearch Operator to enable logging on the cluster.

On Kibana, I am only able to see the logs from certain namespaces and not all the namespaces I have. How do I configure Fluentd to read logs from all pods in all namespaces?

I do not have a Fluentd service account (It was not created with the installation of the operator).

Also, the namespaces from which I don't see any logs have a node selector mentioned in them. Could that be a reason why the logs are not available?

1

Million dollar question - are you running your fluentD as a DaemonSet? If not, there's a chance that fluentd simply isn't running on the node where some containers live.

Otherwise, my best guess is, it's missing permissions to read from all namespaces, especially since you mentioned you haven't attached a ServiceAccount to it. If you used a public FluentD Helm chart such as this one, try making sure you're deploying it with rbac enabled, i.e.:

rbac:
  create: true

serviceAccount:
  create: true

It'll also help if you post some logs from your fluentd container.

1
  • Yes. my issue was htat fluentd was not running on all nodes. My fluentd is running as a DameonSet. – Vini Apr 6 at 7:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.