1

I've setup an "Application Load balancer" in AWS. It has two Listeners, one on HTTP (port 80) and one on HTTPS (port 443). It also has one target group that with only one FARGATE instance that I've registered in ECS.

In the Image below you can see the two listeners and the SSL Cert. I've attached to the HTTPS listener. You can also see that they have the same rule defined. Both of them target the same TargetGroup, over HTTP (port 80). From what I've understood that's an accepted practice to have a Load balancer listen to HTTPS but forward the request over HTTP since it's in the same VPC.

But for some reason only the HTTP listener is working. I've visited the site over HTTPS both directly through the LB's DNS Name and the domain I've attached to the SSL cert. both I both of the give the same result, it loads a while until it gets a timeout.

Any guess what could be wrong?

enter image description here

1

I solved it, I had forgotten that I had to add port 443 to the security group that my load balancer group belongs to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.