0

Despite of the fact runner is alive. Why this error is coming

enter image description here

1 Answer 1

3

You need to either configure the runner to run untagged jobs, or tag your job to use the runner.

To configure the runner to run untagged jobs:

  1. Go to the project’s Settings > CI/CD and expand the Runners section.
  2. Find the runner you want to pick untagged jobs and make sure it’s enabled.
  3. Click the pencil button.
  4. Check the Run untagged jobs option.
  5. Click the Save changes button for the changes to take effect.

Ref: https://docs.gitlab.com/13.12/ee/ci/runners/#use-tags-to-limit-the-number-of-jobs-using-the-runner

To add a tag to your job:

job:
  tags:
    - ci

Ref: https://docs.gitlab.com/ee/ci/yaml/#tags

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.