2

Trying to use a customer registry from a Windows 10 system - a native Docker client in PowerShell.

PS > docker --version

Docker version 17.06.0-ce, build 02c1287
PS > docker pull REPO_URL/foo-bar:0.1

Error response from daemon: get https://REPO_URL/v2/: x509: 
certificate signed by unknown authority.

Importing the authority certificate to local user store via Windows tooling works for itself but has no effect here.

  • 1
    You may wish to follow the steps on this Issue comment – Tensibai Jul 11 '17 at 12:54
  • works! now, shall I delete this question? – Peter Jul 11 '17 at 13:39
  • 1
    You may wish to self answer with the steps you did to make it work and maybe extend a little about how it differs on win10 than previous versions ? – Tensibai Jul 11 '17 at 13:51
  • exactly those steps worked, with the only difference I did a right-click import and then had to copy over the certificate. Is that a valuable answer here? – Peter Jul 11 '17 at 14:19
  • 1
    I'd say yes, working with certificates is always a pain and it seems the official doc doesn't cover this point properly. – Tensibai Jul 11 '17 at 14:22
6

The official Docker documentation says:

Docker recognizes certs stored under Trust Root Certification Authorities or Intermediate Certification Authorities.

That is, you can proceed as the following:

  • Start > "Manage Computer Certificates" (also available in the control panel)
  • Right-click on "Trusted Root Certification Authoritites" > "All tasks" > "Import"
  • Browse to the crt file and then keep pressing "Next" to complete the wizard
  • Restart Docker for Windows

In my case, the catch was that I imported the certificate via the context menu, and therefore it went to another folder where Docker could not access it. The certificate store behaves however very much like the normal Windows Explorer tree folder, so I had just to copy the certificate over to the supported category, and after Docker restart it worked.

  • I had 5 certificate files (.crt): root, server, server-chained, client, client-chained. First 3 is used in private docker-registry accessible via UI through SSL. Now which (out of 5) to be imported into windows ?? – SACn Dec 19 '17 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.