I have a Kubernetes running Rancher 2.4.3. I have the cluster monitoring enabled in rancher, so that exists a Prometheus instance running, so as a Prometheus Operator.

Recently I deployed a Apache Camel-K operator, and now I want to enable the prometheus integration for collect metrics about my camel routes.

So, my Camel-K operator is running in namescape camel-k and the rancher embedded prometheus stack in cattle-prometheus namespace.

I just have launched my route with the trait --trait prometheus.enabled=true, but the camel metrics aren't listing at my prometheus.

Anyone knows why or what I need to configure to my camel-k route deploy it's metrics at the rancher embedded prometheus?

1 Answer 1


Solved updating the prometheus operator 0.38.1 -> 0.39.0.

More details: https://github.com/apache/camel-k/issues/2794

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.