0

When I look at different resources on OpenStack, I see a FQDN's like this,

  • host-10-2-67-96.openstacklocal.
  • host-2620-0-28a4-4140-f816-3eff-fefd-6381.openstacklocal.

I see this for ports and for NOVA instance. Does this mean there is a resource in OpenStack that can resolve this? If there is nothing that can resolve this, what does the FQDN's even do? What purpose do they serve?

I've tried under Network Topology → Networks → (only option) → Subnet Tab → ipv4, which lists two different DNS servers (10.0.18.100 and 10.0.18.200) but neither of them actually resolve these FQDNs. I've tried to dig <fqdn> @ip where ip is each of the above, and I've tried setting my resolve.conf to,

domain openstacklocal
search openstacklocal
nameserver 10.0.18.100
nameserver 10.0.18.200

It's like those two IPs are not getting the entries for the FQDN.


For more information I can see the subnet that my hosts are connected on, but it seems I can find more information about the associated project.

(openstack) subnet show 2fa15774-4724-4796-9a84-813f7a4079d3
+----------------------+--------------------------------------------------------------------------------------------------------------------------------------------------+
| Field                | Value                                                                                                                                            |
+----------------------+--------------------------------------------------------------------------------------------------------------------------------------------------+
| allocation_pools     | 10.2.64.11-10.2.95.254                                                                                                                           |
| cidr                 | 10.2.64.0/19                                                                                                                                     |
| created_at           | 2021-02-25T16:39:29Z                                                                                                                             |
| description          |                                                                                                                                                  |
| dns_nameservers      | 10.0.18.100, 10.0.18.200                                                                                                                         |
| dns_publish_fixed_ip | None                                                                                                                                             |
| enable_dhcp          | True                                                                                                                                             |
| gateway_ip           | 10.2.64.1                                                                                                                                        |
| host_routes          |                                                                                                                                                  |
| id                   | 2fa15774-4724-4796-9a84-813f7a4079d3                                                                                                             |
| ip_version           | 4                                                                                                                                                |
| ipv6_address_mode    | None                                                                                                                                             |
| ipv6_ra_mode         | None                                                                                                                                             |
| location             | cloud='', project.domain_id=, project.domain_name=, project.id='0fd8601348b7412da9347a19d49fc4be', project.name=, region_name='RegionOne', zone= |
| name                 | hou-prod-external-ipv4                                                                                                                           |
| network_id           | 990d1b13-88b2-453e-975c-d757b0ed99fb                                                                                                             |
| prefix_length        | None                                                                                                                                             |
| project_id           | 0fd8601348b7412da9347a19d49fc4be                                                                                                                 |
| revision_number      | 0                                                                                                                                                |
| segment_id           | None                                                                                                                                             |
| service_types        |                                                                                                                                                  |
| subnetpool_id        | None                                                                                                                                             |
| tags                 |                                                                                                                                                  |
| updated_at           | 2021-02-25T16:39:29Z                                                                                                                             |
+----------------------+--------------------------------------------------------------------------------------------------------------------------------------------------+

But when I try to get more information on it, I get

(openstack) project show 0fd8601348b7412da9347a19d49fc4be
You are not authorized to find project with the name '0fd8601348b7412da9347a19d49fc4be'.

So it seems that default subnet for my nova instances is on a subnet which is associated with a project that I can not find more information on. Moreover, that subnet has for DNS servers "10.0.18.100, 10.0.18.200" and it seems neither of them can resolve the hostnames for the machines on that subnet. Why is this?

1 Answer 1

0

Usually, depending on how the cloud was configured, Openstack should let you resolve internal DNS names (inside the openstacklocal domain).

This means you will need :

  1. A VM inside a private internal network.
  2. A private network configured to use the internal dnsmasq agents as DHCP (and not any external servers)

It's hard to say in your case but you might be using two different networks. Your DNS servers seem to be in a different subnet than the IP that is assigned to your server.

3
  • The subnet the VMs are on is 10.2.64.0/19. So it's true the DNS nameserver I'm using for resolving is on a different subnet. But that's the one that's getting assigned to the VM's I'm spinning up. Is there another non-default that my OpenStack has that will resolve .openstacklocal domains? Feb 23, 2022 at 3:22
  • I've updated with more information Feb 23, 2022 at 16:44
  • Also a follow up question devops.stackexchange.com/q/15504/18965 Feb 23, 2022 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.