We have Jenkins running on a Windows machine behind a company proxy. I am getting a strange behavior/error when using diffrent kind of users and try to update plugins. The jenkins update site has a proxy exception. So i don´t need a proxy verification for updating plugins and jenkins. We have tested this and it is working.

What is working is when we run the Service as an normal user we also have to specify the proxy server and port. We can specify a User and password or without an user add http://updates.jenkins.io/ to the No Proxy Host list.

If Jenkins is running as local System we get following error:

sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
    at java.base/sun.security.provider.certpath.SunCertPathBuilder.build(SunCertPathBuilder.java:141)
    at java.base/sun.security.provider.certpath.SunCertPathBuilder.engineBuild(SunCertPathBuilder.java:126)
    at java.base/java.security.cert.CertPathBuilder.build(CertPathBuilder.java:297)
    at java.base/sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:434)

Our IT has so called functional user which we want to use for running the jenkins Services. When we run the Jenkins service with a functional user we get the same error as above. It does not matter if we set the proxy or not.

I have looked this error up on stackoverflow and tried most of the solution proposed here without any success. For obvious security reasons I didn't want to disable the certificate check.

So my question is what is the difference between functional user and normal user which creates this error when updating plugins. What could help me else, would be a possible investigation direction. What can I do to get more information about my problem.

  • This is caused by out of date java installations not being able to handle let's encrypt certificates so it is not recognizing the jenkis.io certs.. Update your java version and / or trust store.
    – Ian W
    Nov 27, 2022 at 7:07
  • @IanW we are running OpenJDK 11.0.16. I can update it to 11.0.17 but I doubt this will help. If Java was the problem it would not work with any user. But with running jenkins with a normal user it works, just when using this functional user we get this error.
    – Moone
    Nov 29, 2022 at 7:24
  • Look under /systemInfo see it's the JDK you expect. Per Jenkins community, it should be higher than 11.0.15. If it's the expected version, then you may have an issue.pThe certs will be inside the <JDK_DIR>/jre/lib/security/cacerts. You may try add the cert per mykong or magicmonster
    – Ian W
    Nov 29, 2022 at 11:12
  • java.home C:\Program Files\Microsoft\jdk- java.runtime.version Its not the Java version
    – Moone
    Dec 13, 2022 at 7:07


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.