0

I have a logging repo that contains filebeat, logstash, elasticsearch, kibana and a setup file, it is running normally on different servers using dockers, but now i am trying to build it on a new server but it didn't work using Debian11. When i run docker compose logs -f setup I got the following Could not resolve host. Is Elasticsearch running? and when I run docker-compose up I got the following Logstash error: open /usr/share/logstash/config/logstash.yml: permission denied Any suggestion? Thanks.

3
  • Can you share more details such as the owner of the file /usr/share/logstash/config/logstash.yml? Are you running docker-compose as root user or any other user?
    – Samit
    Dec 31, 2022 at 16:18
  • @Samit How can i check that and how can i change the permission?
    – IDev
    Jan 1, 2023 at 13:33
  • @Samit I don't have the following directory, i am using docker, i think it is installed inside docker
    – IDev
    Jan 2, 2023 at 7:32

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.