0

I'm trying to set up a VPN client in a Docker service with Docker Compose, but I'm running into some issues.

ExpressVPN: I tried this ExpressVPN container, but it just keeps restarting constantly. Here's my code:

expressvpn:
  container_name: expressvpn
  image: polkaned/expressvpn
  environment:
    - ACTIVATION_CODE=<code>
  cap_add:
    - NET_ADMIN
  devices: 
    - /dev/net/tun
  stdin_open: true
  tty: true
  command: /bin/bash
  privileged: true
  ports:
    - 6881:6881 # QBittorrent
  restart: unless-stopped

OpenVPN: I tried installing this DockOVPN client, but the instructions say to run this command to set up/configure:

docker run -it --rm --cap-add=NET_ADMIN \
    -p 1194:1194/udp -p 80:8080/tcp \
    -e HOST_ADDR=$(curl -s https://api.ipify.org) \
    --name dockovpn alekslitvinenk/openvpn

When I run that I get this error:

WARNING: The requested image's platform (linux/amd64) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested

standard_init_linux.go:219: exec user process caused: exec format error

I also tried this linuxserver.io OpenVPN client, but this one is also restarting constantly.

Long story short, I'm just trying to find any dockerized VPN client that works. Can anyone either tell me what I'm doing wrong or recommend an alternate solution?

1 Answer 1

1

You are trying to run an x86 image on a non-x86 processor. That will not work.

You need to find or build an image for the linux/arm64/v8 platform, and use that. You can read more about multi platform images at https://docs.docker.com/build/building/multi-platform/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.