I'm trying to create a Dockerfile based on Ubuntu 22.10 that has some way of remote access (XRDP/VNC/etc.)

I basically installed xfce4 along with xrdp, according to guides on installing it on linux normally (and even managed to install in normally on my linux distro so that means the steps should work), but after logging in to the user in the RDP screen, I get a black screen.

Also tried with VNC, and after connecting I get a grey screen.

I then tried the same steps of installing xfce4 and xrdp on a Dockerfile base on Ubuntu 18 and it worked fine.

What am I missing?

Below are the relevant parts of my Dockerfile:

ENV DEBIAN_FRONTEND noninteractive
RUN apt update && apt install -y \
    xfce4 \

USER tester
RUN echo "startxfce4" > ${HOME}/.Xclients
RUN chmod +x ${HOME}/.Xclients
RUN echo "xfce4-session" > ${HOME}/.xsession

This is the entrypoint script:

set -xe


$(which sshd) -D

Here are my container logs when connecting via RDP: https://pastebin.com/zgPjbaic


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.