0

When I run helm dependency build I get

Error: can't get a valid version for repositories ingress-nginx. Try changing the version constraint in Chart.yaml

I've tried all kinds of things the version,

1.x.x
~1
^1

Everything generates that error. This the relevant part of my Chart.yaml

- name: ingress-nginx
    repository: https://kubernetes.github.io/ingress-nginx
    version: 1.x.x

1 Answer 1

0

App Version vs Chart Version

There are two pieces of software in play with different version numbers,

The helm dependency version field is for the version of the chart. Not the upstream software being packaged.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.