0

We've migrated from a on premise GitBlit to Azure DevOps last week.

Our builds are now suffering from periodic error while cloning the git repo. See example output. Main error is probaby returned status code 128

We are doing quiet a number of builds a day, and each build has multiple checkouts of different git repositories.

Anybody has a clue?


04:51:50 ERROR: Error cloning remote repo 'origin' 04:51:50 hudson.plugins.git.GitException: Command "C:\jenkins_opt\Git\bin\git.exe fetch --tags --force --progress --depth=1 -- https://[email protected]/company/GLIMS/_git/glims_glims-bin +refs/heads/:refs/remotes/origin/" returned status code 128: 04:51:50 stdout: 04:51:50 stderr: warning: ----------------- SECURITY WARNING ---------------- 04:51:50 warning: | TLS certificate verification has been disabled! |


error: RPC failed; curl 56 Recv failure: Connection was reset 04:51:50 fetch-pack: unexpected disconnect while reading sideband packet 04:51:50 fatal: early EOF 04:51:50 fatal: fetch-pack: invalid index-pack output


1 Answer 1

0

Enable TLS Certificate Verification: It's important to enable TLS certificate verification for secure connections. You can do this by configuring Git with the correct SSL certificates or CA certificates. Jenkins might not have the necessary certificates installed or configured.

Check Your Network Connection: The "Connection was reset" error could be related to network issues. Ensure that your Jenkins server has a stable and reliable network connection. If this is a recurring problem, consult your network administrator.

Update Git and Jenkins: Ensure that you are using an up-to-date version of Git on your Jenkins server. Make sure Jenkins and its plugins are also up-to-date. Sometimes, updating Jenkins and its plugins can resolve compatibility issues that might lead to Git errors.

Troubleshooting/Debugging: You can try to enable Git trace/debugging to get more detailed information about what's happening during the fetch operation. You can do this by setting the GIT_TRACE and GIT_CURL_VERBOSE environment variables to "1" or "true."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.