0

I have followed the instructions to install AWX from this site.

https://computingforgeeks.com/install-and-configure-ansible-awx-on-centos/

But I'm unable to create manual SCM project on new project on ansible AWX. I get the below error message.

There are no available playbook directories in /var/lib/awx/projects. Either that directory is empty, or all of the contents are already assigned to other projects. Create a new directory there and make sure the playbook files can be read by the “awx” system user, or have AWX directly retrieve your playbooks from source control using the Source Control Type option above.

enter image description here

1 Answer 1

0
  1. awx system account needs having read permission on the directory and all files/playbooks in it.
  2. I tried and it needs to reboot the AWX server once in order for AWX to index that manual project directory so that it will be available in the drop down list.

Good luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.