1

when I tried to use crictl to list all images like this in Debian 12:

root@k8sslave01:/etc# crictl images
IMAGE               TAG                 IMAGE ID            SIZE

did not show any images. the ctr list works fine:

root@k8sslave01:/etc# ctr images list
REF                                                           TYPE                                                      DIGEST                                                                  SIZE      PLATFORMS                                                                    LABELS
registry.cn-hangzhou.aliyuncs.com/google_containers/pause:3.6 application/vnd.docker.distribution.manifest.list.v2+json sha256:3d380ca8864549e74af4b29c10f9cb0956236dfb01c40ca076fb6c37253234db 294.7 KiB linux/amd64,linux/arm/v7,linux/arm64,linux/ppc64le,linux/s390x,windows/amd64 -
registry.k8s.io/pause:3.6                                     application/vnd.docker.distribution.manifest.v2+json      sha256:8a9b8e25874aac2f58bc7d523e55c4a98f03653d109f3acc77cd064544f906f4 290.9 KiB linux/amd64

Am I missing something? what should I do to fixed this issue? this is the /etc/crictl.yaml config:

root@k8sslave01:/etc# cat /etc/crictl.yaml
runtime-endpoint: unix:///var/run/containerd/containerd.sock
image-endpoint: unix:///var/run/containerd/containerd.sock
timeout: 10
#debug: true
debug: false

I have already tried to import the images like this:

root@k8sslave01:~# ctr image import /root/pause.tar --all-platforms
unpacking registry.k8s.io/pause:3.6 (sha256:8a9b8e25874aac2f58bc7d523e55c4a98f03653d109f3acc77cd064544f906f4)...done

still could not show by crictl command.

1 Answer 1

1

Finally I found the crictl default namespaces in k8s.io, when import images, we should specify the namespaces like this:

ctr -n=k8s.io image import /root/pause.tar

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.