-1

The problem:

The information for my Minikube cluster is supposed to be showing up under the Kubernetes tab for a Backstage component similar to the following images:

enter image description here

[enter image description here2

However, I am getting the following message under the Kubernetes tab for a Backstage component instead:

[enter image description here3

What I've done so far and what I think some potential sources of my error are:

I have successfully set up Minikube in my terminal and created a Minikube cluster using this online documentation article: https://minikube.sigs.k8s.io/docs/start/. On my Kubernetes Dashboard, I can see that my cluster exists and that there is 1 pod for it.

I am currently integrating Minikube with Backstage using two online documentation articles: https://backstage.io/docs/features/kubernetes/ (Backstage official documentation) and https://john-tucker.medium.com/backstage-and-kubernetes-by-example-3b49725e8acb (another article). I have followed all the steps up until the 'Configuration' page in the Backstage official documentation. I have followed all the steps until the 'Creating a Kubernetes Enabled Component' heading in the other article. I tried following some of the steps after the heading but it seemed to involve creating another file in my local Backstage codebase to manually add a Minikube cluster which would then be shown in Backstage, but I wanted my already-created Minikube cluster to be loaded into Backstage automatically.

I created a GitHub repository and added an annotation to the catalog-info.yaml file in the GitHub repository (one of the ways to create a new Backstage component involves pasting a link to a GitHub repository with a catalog-info.yaml file). I created a new Backstage component using the link to this repository. When I clicked on the Kubernetes tab of this component, instead of any information for my cluster showing up, I got an error message (in the 'message' image from above). I am not sure how to fix this error as I have tried a lot of different configurations and commands but none of them have worked.

I think a potential source of my problems could be that my app-config.yaml file is not properly configured. I have tried many different values for the 'url' field but none of them seem to work.

[enter image description here4

I also wonder if it is even feasible to automatically load information about a Minikube cluster into Backstage?

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.