0

I'm facing an issue with accessing the Harbor after deploying it on Kubernetes using Helm. Here are the steps I followed:

  1. Download Harbor helm chart:

helm repo add harbor https://helm.goharbor.io helm fetch harbor/harbor --untar

  1. Install the Harbor helm chart with a release name my-release:

helm install my-release

  1. Port forwarded to access the Harbor portal:

kubectl port-forward --address 0.0.0.0 svc/my-release-harbor-portal 9000:8080

I'm unable to access the Harbor portal at http://localhost:9000. The default username is admin, and the password is Harbor12345. However, the login credentials are not working, and I'm seeing the following error: Invalid user name or password. enter image description here

I've checked the Harbor pods, services, and Helm release, but I'm unable to identify the issue. Any guidance or suggestions would be greatly appreciated.

I attempted the following steps:

  1. Checked the status of Harbor pods using kubectl get pods.
  2. Verified the Helm release with helm list.
  3. Examined the services using kubectl get services .
  4. Checked the Harbor logs with kubectl logs.
  5. Reviewed the Helm chart values for any misconfigurations.
2
  • Have you tried doing port of forward of Nginx pod and then do the login ? as far as i know authentication is handled by Nginx and not Harbor portal it self. Dec 5, 2023 at 12:08
  • Incase if you do not have an nginx then it could be related to the expose type of Harbor service and not supporting port forwards as discussed here in detail github.com/goharbor/harbor-helm/issues/565 Dec 5, 2023 at 12:21

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.