0

When installing OMD 1.3 on Ubuntu, I get the following output:

dpkg: dependency problems prevent configuration of omd-1.31.20160708:
omd-1.31.20160708 depends on libapache2-mod-proxy-html; however: Package libapache2-mod-proxy-html is not installed. 
omd-1.31.20160708 depends on apache2-mpm-prefork; however: Package apache2-mpm-prefork is not installed.
omd-1.31.20160708 depends on libboost-program-options1.54.0; however: Package libboost-program-options1.54.0 is not installed.
omd-1.31.20160708 depends on libboost-system1.54.0; however: Package libboost-system1.54.0 is not installed.
omd-1.31.20160708 depends on libperl5.18; however: Package libperl5.18 is not installed.
omd-1.31.20160708 depends on php5-cli; however: Package php5-cli is not installed.
omd-1.31.20160708 depends on php5-cgi; however: Package php5-cgi is not installed.
omd-1.31.20160708 depends on php5-gd; however: Package php5-gd is not installed.
omd-1.31.20160708 depends on php5-mcrypt; however: Package php5-mcrypt is not installed.
omd-1.31.20160708 depends on php5-sqlite; howeve 
dpkg: error processing package omd-1.31.20160708 (--install): dependency problems - leaving unconfigured

I have updated and upgraded my system quite a few times and still issue persists and has confirmed that the dependencies exist.

Does anybody know if the above packages and their versions are required? I have the dependencies installed, but on the latest version and I am assuming that OMD and the packages that comes with it requires the older version.

Any advise or solutions to this issue?

System:Ubuntu 16.04.3 LTS OMD Version: 1.31.20160708

1
  • That's very unclear what your problem could be, what does dpkg -l libapache2-mod-proxy-html give for exemple ?
    – Tensibai
    Aug 30 '17 at 8:54
2

According to How to let dpkg -i install dependencies for me? it sounds like dpkg doesn't have support for automatically installing a package's dependencies.

Personally I'd switch to a package manager which has such support, like apt-get. You'll like it ;)

Alternatively you could:

  • use a "helper" application around dpkg as suggested in the above-mentioned answer
  • manually collect the entire list of missing dependencies and install them as well. But it can be very tedious.

I have the dependencies installed, but on the latest version

The version is part of the dependency, so technically the above means you don't actually have the dependencies installed. At least not for that particular version of OMG.

and assuming that OMD and the packages that comes with it requires the older version?

Bingo. You have 2 options:

  • re-create an older version of your system which is compatible with your particular version of OMD. It could be based on Docker or some VM technology (or some plain old hw you may have lying around). I won't consider downgrading your system a solution :)

  • look for a newer version of OMD, hopefully one that's happy with what you have installed and on which its dependencies can be installed (some packages suport multiple versions installed on the same system). Also note from omdistro.org, you may be looking for another package:

With the growing popularity of OMD, we came to a point were it makes sense to develop two specialized versions of OMD.

  • Check_MK Raw: Check_MK Raw Edition focuses on Check_MK. Use this if you mainly use Check_MK. This is a smaller package including all components to run Check_MK.
  • OMD-Labs: OMD-Labs contains all components of the original omd and some more addons like Grafana and Influxdb as well as Naemon and Icinga 2.
2
  • 2
    I can't swear but I think that when the problem is a version conflict dpkg tells the package is installed but in a version not compatible, here it says it is not installed. ..
    – Tensibai
    Aug 30 '17 at 15:41
  • Hi guys, I think my issue is just required version. my machine is updated till whatever is the latest version, including the dependancies. OMD is also on the latest version, which according to their repo, is 1.3x. I think as Dan has said, potentially the only thing to do is revert back to the required versions of OMD dependancies. Not what I wanted to hear :-) lol, but sometimes the truth hurts hehehehehehe Sep 2 '17 at 10:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.