0

I use a docker-compose.yml file to boot my containers. My container mount to a external volume which targets a directory inside my user profile (postgres database files). However, after switching from Windows (using Docker for Windows) to Fedora (and also to Podman), i cannot mount my volume any more because of permission issues. When i add the :Z Flag at the end of my mount, then everything works. However: The big problem is, that i cannot add the flag because my colleagues who still are on Windows cannot use this docker-compose.yml file any more because docker complains about the :Z flag.

Is there a OS level solution for this?

What i've tried so far: these commands (while i am in the project directory (which is the same directory, my mount points into) sudo semanage fcontext -a -t svirt_sandbox_file_t "$(pwd)(/.*)?" sudo restorecon -Rv "$(pwd)"

background info: I am a software developer. the docker-compose.yml is committed to my git repo. the postgres database files are part of the git project (however, they are in the .gitignore file). I've checked out the project into a directory inside my user profile. therefore the docker-compose.yml as well as the target directory of my mountpoint are both in separate directories inside my user profile.

Any ideas?

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.