8

I have a fresh aws instance with Ubuntu 14 installed.

I am trying to install and run jenkins on it. I did the following steps.

Installed java8

wget -q -O - https://pkg.jenkins.io/debian/jenkins-ci.org.key | sudo apt-key add -
sudo sh -c 'echo deb http://pkg.jenkins.io/debian-stable binary/ > /etc/apt/sources.list.d/jenkins.list'
sudo apt-get update
sudo apt-get install jenkins

sudo apt-get update
sudo apt-get install jenkins

After that I checked the status of the Jenkins server

sudo service jenkins status

The response was:

Jenkins Automation Server is running with the pid 8355

sudo netstat -ntulp | grep 8080
tcp6       0      0 :::8080                 :::*                    LISTEN      8356/java  

However, when I go to ipaddress of <aws_instance_ip_address>:8080 the page does not load.

Going to <aws_instance_ip_address> opens the Ubuntu Apache default page.

What do I need to do for Jenkins to launch from browser?

3
  • Are you navigating to the correct AWS ec2 url (ec2-[IP].compute-1.amazonaws.com)? Are your security groups configured correctly?
    – Preston Martin
    Sep 21 '17 at 15:15
  • Is your host firewall open on port 8080?
    – jayhendren
    Sep 22 '17 at 4:24
  • do you get a response from jenkins if you curl localhost:8080 on the jenkins host? what about curl <aws_instance_ip_address>:8080 on the jenkins host?
    – jayhendren
    Sep 22 '17 at 4:24
6

It seems your have not opened your 8080 port in Security Groups in AWS.

Steps:

  1. Go to AWS console

  2. Click Security Group and select the security group that you have assigned to your EC2 instance.

  3. Click Edit Inbound Rules

  4. Add a Custom TCP Rule and add 8080 in the Port Range.

  5. You will now see Jenkins rise from the grave :) i.e. first time installation screen.

P.S.: My Friend, if you have reached till Step 5, you know what to do next ;)

2

I had reposted this question in stackoverflow. https://stackoverflow.com/questions/46339167/jenkins-installed-on-aws-unable-to-launch-on-browser

The answer in comment "open the port 8080 in Ec2 security groups" resolved the issue for me.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy