1

Puppet Master:

  • Docker container with cent-OS-6
  • configured in /etc/hosts
  • configured /etc/puppet/puppet.conf with server,dns_alt_names and certname

Puppet Agent:

  • Docker container with ubuntu OS
  • configured serverip and agent ip in /etc/hosts
  • configure /etc/puppet/puppet.conf with server value

NOW trying to Generate Certificate in SERVER Machine with

sudo -u puppet puppet master --no-daemonize --verbose

Displays:Notice: Starting Puppet master version 3.8.7

Nothing happens related to Certificate Generation.

I believe there aint any mistake in hosts file and other configuration missing. here might have things gone wrong.

In the client machine If I run this command puppet agent -t . I get the following error. As the certificate is not generated in server. I think I have to fix that first than this .

Warning: Unable to fetch my node definition, but the agent run will continue:
Warning: Server hostname 'www.puppetmaster.com' did not match server certificate; expected one of puppetcertificate, DNS:puppet www.puppetmaster.com, DNS:puppetcertificate
Info: Retrieving pluginfacts
Error: /File[/var/lib/puppet/facts.d]: Failed to generate additional resources using 'eval_generate': Server hostname 'www.puppetmaster.com' did not match server certificate; expected one of puppetcertificate, DNS:puppet www.puppetmaster.com, DNS:puppetcertificate
Error: /File[/var/lib/puppet/facts.d]: Could not evaluate: Could not retrieve file metadata for puppet://www.puppetmaster.com/pluginfacts: Server hostname 'www.puppetmaster.com' did not match server certificate; expected one of puppetcertificate, DNS:puppet www.puppetmaster.com, DNS:puppetcertificate
Info: Retrieving plugin
Error: /File[/var/lib/puppet/lib]: Failed to generate additional resources using 'eval_generate': Server hostname 'www.puppetmaster.com' did not match server certificate; expected one of puppetcertificate, DNS:puppet www.puppetmaster.com, DNS:puppetcertificate
Error: /File[/var/lib/puppet/lib]: Could not evaluate: Could not retrieve file metadata for puppet://www.puppetmaster.com/plugins: Server hostname 'www.puppetmaster.com' did not match server certificate; expected one of puppetcertificate, DNS:puppet www.puppetmaster.com, DNS:puppetcertificate
Error: Could not retrieve catalog from remote server: Server hostname 'www.puppetmaster.com' did not match server certificate; expected one of puppetcertificate, DNS:puppet www.puppetmaster.com, DNS:puppetcertificate
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run
Error: Could not send report: Server hostname 'www.puppetmaster.com' did not match server certificate; expected one of puppetcertificate, DNS:puppet www.puppetmaster.com, DNS:puppetcertificate
1
  • don't install 3.8.7, don't use centos 6 ...
    – Vorsprung
    Oct 30 '17 at 10:42
2

First, try setting dns_alt_names in /etc/puppet/puppet.conf:

[main]
    dns_alt_names = www.puppetmaster.com
[master]
    autosign = true

Then see if your puppet-agent -t run works properly. be sure that you have properly set your server on the puppet client in /etc/puppet/puppet.conf too:

[agent]
    server = www.puppetmaster.com

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.