I have a vagrant box running on windows 10 hyper-v

config.vm.box = "kmm/ubuntu-xenial64" #A standard Ubuntu 16.04 LTS (x64).
config.vm.provider "hyperv"

Just after provisioning it, it seems to be running o.k. but then if I exit and ssh back to it then trivial actions such as pressing tab after typing cd /vag would take tons of time (e.g 30 sec or more) and after that a cd /vagrant worked o.k. then ls -la worked o.k. and another ls -la took something like 3 minutes or so.

During that time hyper-v is showing the virtual machine at 0% CPU.

Any suggestions on where I should look to try and figure out why is this happening?

1 Answer 1


It seems ther reason for this was that the SMB connections would disconnect. using

net config server /autodisconnect:-1

in a "run as administrator" command window fixed it.

as explained here: https://www.vagrantup.com/docs/synced-folders/smb.html#preventing-idle-disconnects

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.