0

Currently trying

 agent {
    kubernetes {
      cloud 'jenkins-jenkins'
      label 'node'
      inheritFrom 'default'
      containerTemplate {
        idleMinutes '60'
        name 'node'
        image 'node'
        ttyEnabled true
        command 'cat'
      }
    }
  }

It has to spin up a new pod each time and does not currently keep the pods for 60 min like I expect.

  • Shouldn't idleMinutes be one layer above (i.e. side-by-side with inheritFrom)? jenkins.io/doc/pipeline/steps/kubernetes – Dan Cornilescu Mar 15 '18 at 22:53
  • WorkflowScript: 11: Invalid config option "idleMinutes" for agent type "kubernetes". Valid config options are [label, containerTemplate, activeDeadlineSeconds, cloud, inheritFrom, instanceCap, nodeSelector, serviceAccount, workingDir] @ line 11, column 7. idleMinutes '60' – David West Mar 16 '18 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.