1

I have 3 hosts and when i try to ping using the command below:

ansible all -i hosts/team_ansible.yml -m ping --user max --ask-pass

Only i get success message from one system and then it hangs for long until User interruption.

mjm@mjm-laptop:~/Team/Projects/builder$ ansible all -i hosts/team_ansible.yml -m ping --user max --ask-pass
SSH password: 
loc1-s1.eco-ha.team.com | SUCCESS => {
    "changed": false, 
    "ping": "pong"
}
.
.

The same happens when i run the playbook as shown below:

mjm@mjm-laptop:~/Team/Projects/builder$ ansible-playbook -i hosts/team_ansible.yml site.yml --ask-pass
SSH password: 
PLAY [all] *********************************************************************
TASK [Gathering Facts] *********************************************************
ok: [loc1-s1.eco-ha.team.com]
.
.

And it hangs after this.

Ansible version i use : ansible 2.5.0 and Ubuntu system.

The same works perfect for my teammate on ansible 2.4.0 and mac.

  • Does ping to the other systems work, i.e. ping hostname? – 030 Mar 26 '18 at 18:40
  • Ping works for all the 3 hosts and also the ssh login works with the passowrd to all 3 systems. – mjm Mar 27 '18 at 7:26
  • Does it work with 2.4.0 on Ubuntu? Did you check github.com/ansible/ansible/issues? – 030 Apr 6 '18 at 19:10
  • I have tried also with 2.4.0 and it is still the same. So checking with the configurations – mjm Apr 8 '18 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.