Microsoft Windows [Version 10.0.14393]
VirtualBox 5.2.8
Alpine Linux Extended 3.7.0

Docker Info

Containers: 0
 Running: 0
 Paused: 0
 Stopped: 0
Images: 1
Server Version: 17.10.0-ce
Storage Driver: overlay2
 Backing Filesystem: extfs
 Supports d_type: true
 Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
 Volume: local
 Network: bridge host macvlan null overlay
 Log: awslogs fluentd gcplogs gelf journald json-file logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 06b9cb35161009dcb7123345749fef02f7cea8e0
runc version: 0351df1c5a66838d0c392b4ac4cf9450de844e2d
init version: 949e6facb77383876aeff8a6944dde66b3089574
Kernel Version: 4.9.65-1-hardened
Operating System: Alpine Linux v3.7
OSType: linux
Architecture: x86_64
CPUs: 1
Total Memory: 1.953GiB
Name: node-4
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Experimental: false
Insecure Registries:
Live Restore Enabled: false

WARNING: No swap limit support

Issue Description

I'm trying to run the bitname-redis-docker image on my Alpine Linux setup on VirtualBox.

docker run --name redis -e ALLOW_EMPTY_PASSWORD=yes bitnami/redis:latest

The container never starts. Inspecting the log it says

Welcome to the Bitnami redis container
Subscribe to project updates by watching https://github.com/bitnami/bitnami-docker-redis
Submit issues and feature requests at https://github.com/bitnami/bitnami-docker-redis/issues
Send us your feedback at [email protected]

INFO  ==> Starting redis...
sed: can't read /opt/bitnami/redis/conf/redis.conf: No such file or directory
14:C 26 Apr 19:38:43.389 # Fatal error, can't open config file '/opt/bitnami/redis/conf/redis.conf'

To further investigate I ran an strace and here is the log output link.

Can someone tell me what's going on here? Am I doing something wrong?

  • Could you indicate whether you solved the issue?
    – 030
    Dec 23, 2019 at 8:38
  • 1
    As far as I can tell it is an error with Alpine. I re-tried with CentOS and everything worked fine. Dec 23, 2019 at 12:33

1 Answer 1


One could also use a docker image from an official docker repository like https://hub.docker.com/r/library/redis/

docker run --name some-redis -d redis:alpine

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.