0

I installed Kubernetes in AWS cloud using KOPS. In aws master node and slave nodes are running running. Now I'm trying from other instance means where i installed the kops that node.

I'm getting output for kops get cluster and other few commands

I'm not able to connect kubernetes master server from my kops instance when i run Kubectl get nodes from my kops instance I'm getting unable to resolve Kubernetes cluster API URL dns: lookup api.uswest2.suman.com on 172.31.0.2:53: no such host

Could any one help me out of this ??

  • Instance 1: Installed kops in this machine and created a cluster then it launches 3 more instances below mentioned
  • Instance 2: Kubernetes Master
  • Instance 3: kube node
  • Instance 4: kube node

Now i'm trying to run Kubectl get nodes from instance 1. I'm getting above error unable to reslove kuberentes cluster.

  • side note: AWS has also an offering for managed Kubernetes. aws.amazon.com/eks – Peter May 30 '18 at 7:17
  • 3
    The problem is just a DNS problem " dns: lookup api.uswest2.suman.com on 172.31.0.2:53: no such host". You'll need to configure your VPC and/or instances to resolve properly each others – Tensibai May 30 '18 at 7:38
  • I have a similar problem/error while creating the cluster. Please share your thoughts. – Manmohan Rawat Aug 11 '18 at 9:05
  • I encountered this last night using a kops-based cluster creation script that had worked previously. I thought maybe switching regions would help, but it didn't. This morning it is working again. This feels like an intermittency on the AWS side. – nobar Jan 24 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.