I'm connected to a cluster which has a release, from a chart, but it was installed by someone else who I think used a tweaked, locally-stored chart.

I don't have access to their original chart/repo. Is there a way I can retrieve it from the cluster, so I can tweak/amend, and re-install it?

Or, can I find the URL of the original repo that was used? The chart name is wordpress-0.6.0, but that's of no use, since it's the same as the "official"/original one.

  • is there a code repository for your infrastructure code? Jun 27, 2018 at 3:55
  • There was, but it was a minor project, and the person/people in question are no longer here - I can't find it Jun 27, 2018 at 10:18
  • Are they willing to do some consulting for their previous employer? An hour of their time could save you days of fruitless searching.
    – chicks
    Jun 27, 2018 at 16:56
  • What does your IT department do with old laptops during off-boarding?
    – chicks
    Jun 27, 2018 at 16:57

4 Answers 4


You can use helm get manifest <RELEASE_NAME> to fetch the kubernets manifests and you can use helm get values <RELEASE_NAME> to get the values.yaml from the cluster. But I don't think there is any way to get the chart files back. Sorry.

PS: Please replace <RELEASE_NAME> with your release name.


To get the package to connect to the helm kubernetes cluster and run helm fetch which will

pull down the char from a repository and (optionally) unpack it in the local directory.

use helm fetch --help to see formating options

Use helm --help to see available commands.

Available Commands: completion Generate autocompletions script for the specified shell (bash or zsh) create create a new chart with the given name delete given a release name, delete the release from Kubernetes dependency manage a chart's dependencies diff Preview helm upgrade changes as a diff fetch download a chart from a repository and (optionally) unpack it in local directory get download a named release history fetch release history home displays the location of HELM_HOME init initialize Helm on both client and server inspect inspect a chart install install a chart archive lint examines a chart for possible issues list list releases package package a chart directory into a chart archive plugin add, list, or remove Helm plugins repo add, list, remove, update, and index chart repositories reset uninstalls Tiller from a cluster rollback roll back a release to a previous revision search search for a keyword in charts serve start a local http web server status displays the status of the named release template locally render templates test test a release upgrade upgrade a release verify verify that a chart at the given path has been signed and is valid version print the client/server version information

  • The cluster isn't a repository - are you sure that would work? Jun 28, 2018 at 21:30
  • 1
    Your right that won't work you don't have anything. Something you might be able to do, which I haven't tried is take the chart you do have and do a diff and see what changes would be applied. That would give you the difference I believe. I can't try that right now. Jun 29, 2018 at 0:00

You can download the latest stable or unstable version from the helm repo. First, You need to verify the remote helm repo URL below command.

# helm repo list

For stable repo URL, you will get output like

NAME            URL
stable          https://kubernetes-charts.storage.googleapis.com

It refers to https://github.com/helm/charts/tree/master/stable

Now I will tell you to download the chart from the repo URL.

helm fetch stable/wordpress --version 0.6.0

For the extracted copy of the chart

 helm fetch stable/wordpress --version 0.6.0 --untar

The above command will download the chart in your current directory.


Below worked for me in helm-3:

  1. Get the name of the release of which you want to get charts using helm list
  2. helm get manifest [release name]

You can write this to some text file instead of stdout and separate the charts. ( Cheers🥂 )

Note: You will need to create persistedVolumes & PVC's. Those are not exported using above command

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.