0

Following is my gitlab.rb file with SMTP configuration for QQ exmail

gitlab_rails['gitlab_email_from'] = "gitlab@example.com"
gitlab_rails['gitlab_support_email'] = "gitlab@example.com"
gitlab_rails['smtp_enable'] = true
gitlab_rails['smtp_address'] = "hwsmtp.exmail.qq.com"
gitlab_rails['smtp_port'] = 465
gitlab_rails['smtp_user_name'] = "gitlab@example.com"
gitlab_rails['smtp_password'] = "PASSWORD"
gitlab_rails['smtp_domain'] = "exmail.qq.com"
gitlab_rails['smtp_authentication'] = "login"
gitlab_rails['smtp_enable_starttls_auto'] = true
gitlab_rails['smtp_tls'] = true
gitlab_rails['smtp_openssl_verify_mode'] = 'peer'

Tried running the following command from gitlab rails console:

Notify.test_email('jake@example.com', 'TEST', 'TEST BODY').deliver_now

Gives the following error:

Net::SMTPAuthenticationError: 535 Error

References:https://docs.gitlab.com/omnibus/settings/smtp.html#qq-exmail

Please advise / help.

  • 535 is the code for authentication error, so I suspect either your user or password have a typo – Tensibai Sep 24 '18 at 11:14
  • @Tensibai I've verified the credentials. Is there something specific required for qq-exmail? – ajinkyapuar Sep 24 '18 at 11:19
  • You'd probabaly have more chances asking qq-exmail, as they're the ones able to check server logs to tell you what's wrong... With a redacted user and password, we can't help you more than guessing... Maybe you should try smtp.qq.com instead of hwsmtp.exmail.qq.com if you follow q's documentation – Tensibai Sep 24 '18 at 11:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.