-1

I'm trying to zip my dist folder and post to it Azure's kudu zipdeploy endpoint but I keep getting this error regardless of the fact that I have installed a zipping package myself.

My docker image: weltn24/up-docker-node-chrome-headless on tag: chrome-66_node-10.0_yarn-1.6.0

The part that fails in my yml file:

build:
  stage: build
  script:
    - apt-get install p7zip p7zip-full
    - yarn install
    - ./node_modules/@angular/cli/bin/ng build --prod
    - cd dist/AngularTemplate; zip -r ../dist.zip *; cd ..; cd..
  artifacts:
    paths:
      - dist.zip

The commands on the 4'th line is failing with zip: command not found.

1

Correct script below:

build:
  stage: build
  script:
    - apt-get install zip unzip
    - yarn install
    - ./node_modules/@angular/cli/bin/ng build --prod
    - cd dist/AngularTemplate; zip -r ../../dist.zip *; cd ..; cd..
  artifacts:
    paths:
      - dist.zip

Was installing the wrong Zip package and then puttin my archive in the wrong folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.