0

I am using RHEL 7.x in AWS. I have Docker 1.13 installed. I checked a variety of ports and no firewall (or Security Group) seems to be blocking network connectivity on the EC-2 host.

I tried this command:

docker run -p 8080:8080 -p 8081:8081 -p 9418:9418 -ti jenkinsci/workflow-demo

I expected it to create a Docker container that will run a Jenkins instance. But that is not what happens. I cannot modify directories on the Docker host.

I therefore tried a different command to potentially do the same thing. Here is that command:

docker run --rm -p 2222:2222 -p 8080:8080 -p 8081:8081 -p 9418:9418 -ti cloudbees/workflow-demo

For the output of both, I get endless cycles of these lines as output:

[4220] [10236] Disconnected [10255] Connection from [::1]:41118 [10255] Extended attributes (16 bytes) exist [10255] Request upload-pack for '/repo' [4220] [10255] Disconnected

Why does this disconnected error keep happening? For learning's sake, I'm curious what is getting disconnected. It appears that the TCP port after the ":" keeps getting incremented with every disconnected statement. I do not understand what the output is all about.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.