0

I am using Ubuntu 18.04 in AWS. I am trying to deploy a Kubernetes cluster with "conjure-up kubernetes". This has worked in the past to create EC-2 instances with Kubernetes.

After I run the above command I choose the spell "Kubernetes Core." I choose the "aws" public cloud. I tried different credentials to be sure. I am using root credentials which have worked in the past. I tried a user with full access to the elastic load balancers. This user had administrator privileges. I tried different regions to be sure. I use "Deploy New Self-Hosted Controller". For the network plugin I tried "flannel" once. I later tried "calico." The problem happened with every combination I tried. It is completely reproducible. This problem recently started. Last week I did not have it. I do not modify the "six applications" in "kubernetes-core." I just press enter for "DEPLOY."

But it immediately fails. I get an error about the "bootstrap-series." The top of my Linux terminal says "Bootstrap controller." Here is the specific message:

'bootstrap-series' Review log messages at /home/ubuntu/.cache/conjure-up/conjure-up.log If appropriate, please submit a bug here: https://github.com/conjure-up/conjure-up/issues/new

I therefore examine the file /home/ubuntu/.cache/conjure-up/conjure-up.log.

The above log has the following:

2018-12-13 03:41:18,576 [ERROR] conjure-up/kubernetes-core - events.py:161 - Unhandled exception in exception=KeyError('bootstrap-series',)> Traceback (most recent call last): File "/snap/conjure-up/1036/lib/python3.6/site-packages/conjureup/controllers/juju/bootstrap/common.py", line 21, in run await self.do_bootstrap() File "/snap/conjure-up/1036/lib/python3.6/site-packages/conjureup/controllers/juju/bootstrap/common.py", line 54, in do_bootstrap credential=app.provider.credential) File "/snap/conjure-up/1036/lib/python3.6/site-packages/conjureup/juju.py", line 244, in bootstrap if app.conjurefile['bootstrap-series']: KeyError: 'bootstrap-series' 2018-12-13 03:41:18,591 [DEBUG] conjure-up/kubernetes-core - init.py:27 - Showing dialog for exception: 'bootstrap-series' 2018-12-13 03:41:22,796 [DEBUG] conjure-up/kubernetes-core - events.py:52 - Setting Shutdown at conjureup/events.py:145 2018-12-13 03:41:22,798 [DEBUG] conjure-up/kubernetes-core - events.py:52 - Received Shutdown at conjureup/events.py:176 2018-12-13 03:41:22,798 [INFO] conjure-up/kubernetes-core - events.py:180 - Shutting down 2018-12-13 03:41:22,798 [INFO] conjure-up/kubernetes-core - app_config.py:192 - Storing conjure-up state 2018-12-13 03:41:22,802 [INFO] conjure-up/kubernetes-core - app_config.py:207 - State saved 2018-12-13 03:41:22,802 [DEBUG] conjure-up/kubernetes-core - events.py:200 - Cancelling pending task: wait_for=()]>>

Looking at the AWS logs, the credentials never access AWS from my Ubuntu server. There is no record the authentication even happens. So the failure is very early in the process after I choose the "DEPLOY" action.

How do I deploy Kubernetes with conjure-up to AWS?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.