0

So, I'm trying to install PiHole on an LXC container, on a remote server. However it's not resolving my queries.

Here are things which I'm sure of:

  1. PiHole has been installed successfully.
  2. It is able to resolve my DNS queries from within the container and from within the host, blocking all the ads.
  3. I'm able to access the web frontend.
  4. I stopped the dnsmasq and systemctl-reloaded service on the host.
  5. I've forwarded ports 80, 443 and 53, to inside the container.

Here is the output for netstat on the host.

tcp        0      0 0.0.0.0:22              0.0.0.0:\*               LISTEN      17229/sshd             
tcp6       0      0 :::4711                 :::\*                    LISTEN      31968/lxd              
tcp6       0      0 :::80                   :::\*                    LISTEN      21138/lxd              
tcp6       0      0 :::53                   :::\*                    LISTEN      12230/lxd              
tcp6       0      0 :::22                   :::\*                    LISTEN      17229/sshd             
tcp6       0      0 :::443                  :::\*                    LISTEN      11735/lxd              
udp     4608      0 0.0.0.0:68              0.0.0.0:\*                           7755/dhclient

What is not working:

DNS queries from outside are not reaching the LXC

I'm not sure what I'm doing wrong. Is there any other port which needs to be opened? Or any other configuration which I'm missing?

Any help or ways to debug the problem will be appreciated!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.