I am writing an R package and using Travis for Continuous Integration. The tests on macOS fail because the system has a newer version of TeXLive and is unable to install the inconsolata font to build vignettes.

The Travis logs show:

sudo tlmgr install inconsolata upquote courier courier-scaled helvetic
tlmgr: The TeX Live versions supported by the repository
do not include the version of the local installation

and further on, R is unable to build the vignettes:

* checking PDF version of manual ... WARNING
LaTeX errors when creating PDF version.
This typically indicates Rd problems.
LaTeX errors found:
! LaTeX Error: File `inconsolata.sty' not found.
Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)
! Emergency stop.
<read *> 

l.276 ^^M

!  ==> Fatal error occurred, no output PDF file produced!
* checking PDF version of manual without hyperrefs or index ... ERROR
Status: 1 ERROR, 1 WARNING

This failure throws a warning for R, which is upgraded to an error because I have warnings_are_errors: true in .travis.yml.

I tried this StackOverflow answer of reinstalling inconsolata in .travis.yml:

  - if [[ "$TRAVIS_OS_NAME" == "osx" ]]; then
      brew cask install basictex;
      sudo tlmgr update --self;
      sudo tlmgr update --all;
      sudo tlmgr install titling framed inconsolata;
      sudo tlmgr install collection-fontsrecommended;

and this TexStackExchange thread of changing the TeX repository and running the same commands as Travis does when installing the system:

  - if [[ "$TRAVIS_OS_NAME" == "osx" ]]; then
      sudo tlmgr option repository http://mirror.ctan.org/systems/texlive/tlnet;
      sudo tlmgr update --self
      sudo tlmgr install inconsolata upquote courier courier-scaled helvetic;

and neither worked.

How can I install the inconsolata font?

1 Answer 1


This issue is due to the CTAN mirrors having yet to update. The issue appears in the Travis R community forum:

might be related to the recent switch to TexLive-2019 as the LaTeX package manager seems to fail finding inconsolata in the repository.


It looks to me like the mirror chosen was has not updated to 2019, so I think this will resolve itself naturally when the mirrors catch up. If not I can look into it.

In the meantime, I solved it by forcing a previous version of TeXLive with a downgrade to OSX 10.12 in .travis.yml:

# macOS 10.12 version
osx_image: xcode9.2

See this Travis page for the correspondence between XCode and OSX versions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.