-6

I'm stepping through the documentation here for installing GitLab Runner. When I register the runner, I get this compatibility error:

ERROR: Checking GitLab compatibility... not-compatible  reason:=Gitlab
Runner >= 9.0 can be used ONLY with GitLab CE/EE >= 9.0 results=405 
runner=FsqqGSrw statusText=405 Method Not Allowed

We're operating on an isolated network with GitLab 8.13.0, and no plan to update at the moment. All I can find in the documentation is this link which provides the latest 9.0 version of the runner.

Does anyone know where I might find older versions of GitLab Runner?

6

As described in the documentation you are following to install on the first paragraph:

You can download a binary for every available version as described in Bleeding Edge - download any other tagged release.

Following the link in this sentence allow your to find the tag list page

Last version in 1.X (Hence compatible with 8.X versions of Gitlab is 1.11.2 at time of writing, you can download it from The tag details page

If you prefer another archive format, you can choose in the dropdown of download at the right of the tag page description:

Tags page view with drop down for download at right

  • 1
    Hey, sorry I didn't had a better answer :) I've tried to be as descriptive as possible of the path I did follow to give you the keys for next time :) – Tensibai Apr 13 '17 at 21:07
1

According to the runner readme, the old version compatible with 8.x can be downloaded from here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.