0

Last week, my TXT and other DNS records on Route53 stopped resolving:

https://dnschecker.org/#TXT/thuijls.net

The entries are set like:

enter image description here

What else could be missing here? As far as I'm aware, nothing has changed in the last week yet most of the entries are not being picked up. The domain was automatically extended earlier september if that makes a difference.

1

When I lookup your domain thuijls.net on MXToolBox I get the following messageL

Dns record not found

They explain this to mean:

More Information About Dns Record Published
We did not find a SPF (TXT) record for the domain. Either you are using the deprecated type "SPF" record (in which case you will see a warning message for this alongside this message) or no record exists.

For a SPF record to be valid, it must at least contain v=spf1

A TXT lookup for thuijls.net yeilds:

Type Domain Name TTL Record
TXT thuijls.net 5 min v=spf1 include:spf.messagingengine.com ?all

The problem is the ?all - you probably copy-pasted this from somewhere and the (non-standard) hyphen became a question mark.

Edit your TX record to read v=spf1 include:spf.messagingengine.com -all and all will be good.

Then you can add a 2nd TXT entry for your "protonmail-verification-da....." setting.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.