1

I've been trying to get a simple jenkins master node to start but it keeps getting stuck at the "Please wait while Jenkins is getting ready to work".

My setup is nothing exotic: jenkins is installed inside a LXC hosted by a proxmox 6 instance. 10Go of RAM, 4CPU, 10G of hdd, debian 9

I increased the lxc specs just in case (I started with 4G of RAM and 2 CPU)

I tried a lot of different things such as:

  1. Stop / start the jenkins soft
  2. Stop / start the container
  3. installing using debian package
  4. Install using the war (see my service file below, only used for the war install style)
  5. Installing on centos 7
  6. Installing on qemu

Service file:

[Unit]
Description=Jenkins Daemon

[Service]
ExecStart=/usr/bin/java -jar /home/jenkins/jenkins.war --logfile=/home/jenkins/jenkins.log
User=jenkins

[Install]
WantedBy=multi-user.target

The log doesn't contain any error except a WARNING :

2019-10-03 12:05:38.516+0000 [id=1] WARNING o.e.j.s.handler.ContextHandler#setContextPath: Empty contextPath

But it always ends at being stuck at this page.

I've searched the web but my google fu seems bad today so here I am.

This sounds crazy to me, jenkins install is supposed to be easy and quite forward, but I can't make it works ...

[Edit] Might be a connection issue, we saw jenkins trying to connect to an ec2 instance... we have some proxy, but did not found the correct options (in Java command) to get through it, any tips welcome

6
  • Which log are you looking at?
    – papanito
    Oct 4 '19 at 4:54
  • @papanito : /var/log/jenkins.log
    – Pier
    Oct 4 '19 at 5:46
  • What about /home/jenkins/jenkins.log ?
    – schaiba
    Oct 4 '19 at 20:18
  • Arf yes sorry, too many tests... whatever logs, they always contains the same anyway ..
    – Pier
    Oct 5 '19 at 6:11
  • what does journalctl tell you?
    – papanito
    Oct 6 '19 at 13:54
0

OK, a good week-end does its job as usual: My issue was indeed caused by my company proxy (a good thing would be to add this requirement in the jenkins doc, i might have missed it anyway). So the fix is actually simple, just need to add the correct options to the jenkins start command, as in:

-Dhttp.proxyHost=<your_proxy_ip_here> -Dhttp.proxyPort=<your_proxy_port_here> -Dhttps.proxyHost=<your_proxy_ip_here> -Dhttps.proxyPort=<your_proxy_port_here>

Full example:

/usr/bin/java -Djava.net.preferIPv4Stack=true -Dhttp.proxyHost=10.21.92.40 -Dhttp.proxyPort=3128 -Dhttps.proxyHost=10.21.92.40 -Dhttps.proxyPort=3128 -jar /usr/share/jenkins/jenkins.war --webroot=/var/cache/jenkins/war --httpPort=8080

tcpdump was the savior here (+ a colleague :) )

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.