13

I have followed the instructions on command line: https://docs.microsoft.com/en-us/azure/devops/repos/git/merging?view=azure-devops&tabs=visual-studio

enter image description here

all I want to do is resolve this merge conflict its complaining about.

To be clear, I have done a git pull, it says Already up to date.

I also tried:

git pull origin feature/ENGA-2514
From ssh.dev.azure.com:v3/nfib/NfibEnterprise/engage.mobile
 * branch                feature/ENGA-2514 -> FETCH_HEAD
Already up to date.

I have also tried:

git log --merge
fatal: --merge without MERGE_HEAD?

Where is this elusive merge conflict?

1
  • I found it impossible to do this on the web UI, I had to do it in Visual Studio instead. As far as I could tell there were zero options in the web UI for resolving conflicts. Mar 5 at 0:27
10

Try this solution: Pull Request Merge Conflict Extension. It helps to resolve conflicts inside the pull request page.

4

I am not sure this tab appears 100% of the time, you still have to merge some cases locally, but you can merge some PRs without any extensions in latest UI update.

merge tool

1
  • It seems this extension does not have checkboxes to pick left or right side on specific conflicts, so you have to manually correct them in the bottom pane. Or pick the entire left/right side.
    – Brain2000
    Feb 25 at 17:52
3

I had this problem too, coming from github where you can usually resolve text file changes in browser.

On your local repo, you want to get the latest then reverse-merge, so in your case

// Precursor to ensure your local is the same as origin
git pull master
git checkout feature/ENGA-2514
git pull feature/ENGA-2514 

// include all of the other branches changes into yours. 
git merge master 

// This is where you'll be able to resolve the conflicts locally 
// and commit the merge into feature/ENGA-2514

git push feature/ENGA-2514

Then your branch wont conflict with master in devops, since youve just merged master into your branch.

0

For me, I cannot resolve these conflicts.

To PREVENT THEM:

  i) Make backups outside the folder system for the repository

 ii) Totally delete your 'local' folder for the repository.  (Seems
     counterintuitive, but it is all that works for me).  

iii) Re-load 'local' folder from the web-repository.

 iv) Eventually, check-in, then it will work.

  v) Repeat step i for next time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.