I tried pulling the windows/nanoserver image.
After that failed I looked around and found this site
Every one of them fails with the same error message

#docker pull mcr.microsoft.com/windows/nanoserver:1909
ltsc2019: Pulling from windows/servercore
no matching manifest for unknown in the manifest list entries

Additional Info:
Docker version: 18.09.2, build 6247962
Win10 Enterprise 2016 LTSB: Version 10.0.14393 Build 14393

2 Answers 2


The problem is twofold:

  • The Win10 LTSB is on its newest version and Docker has stopped supporting this version.
    This stops Docker from updating.

  • Microsoft has moved to its own container registry and in doing so abandoned support for older Docker versions. So while I was pulling from the right registry it could not find a fitting image.

Solution: get an up-to-date, non-LTSB version of Windows

Additional Info:
While the error message did not help in finding the cause the docker log did:

[WindowsDaemon  ][Info   ] debug: a Windows version 10.0.18363-based image is incompatible with a 10.0.14393 host

seems support ended for above mentioned image its no longer in their registry maybe


  • While they stopped using the docker CR, the docker pages for the images list the correct link to mcr.microsoft.com
    – Dawnkeeper
    Commented Dec 3, 2019 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.