Questions tagged [alpine]

For DevOps questions related to Alpine Linux or Alpine-based containers.

Filter by
Sorted by
Tagged with
0 votes
1 answer

Can you use the Secure File API if the container doesn't have bash? Like Alpine?

GitLab offers a Project-level Secure Files, the API has you add this to your .gitlab-ci.yml, test: variables: SECURE_FILES_DOWNLOAD_PATH: './where/files/should/go/' script: - curl --silent ...
Evan Carroll's user avatar
  • 1,794
0 votes
1 answer

Buildkit failing arm builds with missing binaries even though they are in $PATH

A few of our developers recently got some M1 machines, I want to provide them with ARM compatible images and have set my sights on Buildkit. I set up a podTemplate in Jenkins and run the build with ...
Kristoffer Sall-Storgaard's user avatar
1 vote
1 answer

Why does running echo with exec form in a Dockerfile create /etc/resolv.conf?

I was trying to build a Docker image from a Dockerfile and I had a line in there which reads: RUN ["echo", "'anything'", ">", "./a_file"] This didn't work, and I eventually had to use: RUN ["sh",...
dayuloli's user avatar
  • 141
5 votes
4 answers

ERROR: Unable to read database state: No such file or directory

I was trying to install Photon by pulling the docker image. But when I run docker build -t photon . I am getting the below error. ---> Running in 3076fb42ef8b ERROR: Unable to read database state:...
Anonymous Platypus's user avatar
2 votes
1 answer

How do I bootstrap an alpine image to work with a private repo proxy behind TLS?

I am in a corporate environment behind a gateway that does DPI and often replaces the TLS certificate of most online resources with our corporate certificate. Many of our developers use images based ...
LLlAMnYP's user avatar
  • 285
0 votes
1 answer

How do -dev apk packages differ on Alpine for the purposes of creating docker images?

I recently started a new position at a company that is transitioning over to docker for local and prod, and inherited a few 'base image' repositories for php, node and a few others. Unfortunately the ...
Max Colledge's user avatar
3 votes
2 answers

Installing azcopy in Gitlab Runner (Alpine Linux)

How can I install azcopy and use it in my gitlab runner CI/CD script? First I have two scripts that download the tar file and extract it. wget -O azcopy.tar.gz
Brad's user avatar
  • 151
0 votes
1 answer

TravisCI build continues to fail even after changing alpine version

So I ran my Docker build with TravisCI and I got a failure like so: FAIL src/App.test.js ● Test suite failed to run TypeError: Cannot assign to read only property 'Symbol(Symbol.toStringTag)' ...
Daniel's user avatar
  • 519
1 vote
1 answer

Error while trying to run docker redis image on Alpine Linux 3.7.0

Specifications Microsoft Windows [Version 10.0.14393] VirtualBox 5.2.8 Alpine Linux Extended 3.7.0 Docker Info Containers: 0 Running: 0 Paused: 0 Stopped: 0 Images: 1 Server Version: 17.10.0-ce ...
Soham Dasgupta's user avatar
0 votes
1 answer

Why won't InSpec admit that port 5432 is listening inside a PostgreSQL container?

Background I'm trying to test a PostgreSQL container with InSpec 2.1.10, but I cannot get a simple port check to return true, even though Docker, netstat, and psql all report that the port is ...
CodeGnome's user avatar
  • 242