Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [elasticsearch]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
1 answer
1k views

How to curl elastic or kibana api for alerts?

I am learning to use the ELK stack. Both kibana and elasticsearch are installed on my localhost. I just learnt how to install metricbeat and how to set up alerts. When setting up the alerts, I used ...
learningtech's user avatar
1 vote
1 answer
982 views

How to monitor ELK using metricbeat on kubernetes (v8 compatible and simple solution)

For probably more than a year there's been a deprecation warning on xpack monitoring in elasticsearch, logstash, kibana etc. saying the built-in monitoring is going to disappear. Since I don't like ...
Kristofer's user avatar
  • 131
1 vote
1 answer
2k views

Unable to connect to Elasticsearch [ Error: Request Timeout after 30000ms ]

I have installed elasticsearch-oss 7.9.2 and kibana 7.9.2 on ubuntu 18.04 when I start elasticsearch service then it's started normally but when I start service kibana it's not starting and shows ...
Jay's user avatar
  • 994
0 votes
1 answer
82 views

Internal proxy for external system

I have a web server in a Kubernetes Deployment which uses an ElasticSearch instance on ElasticCloud. I have parameterised (thanks to environment variables) my container, from a Secret, with this kind ...
GlinesMome's user avatar
0 votes
1 answer
191 views

ECK - Install Plugins: Error privileges

My setup: AWS EKS * Platform: eks.3 * K8s: 1.18 ECK (Elastic Cloud Kubernetes): * Deployment via: Operator * Elasticsearch version: 7.10.1 Summary I'm trying to install the repository-s3 plugin at ...
Vader's user avatar
  • 466
0 votes
1 answer
835 views

Elasticsearch on Docker - file permission issues

I am trying to test LDAP in elasticsearch/kibana by running it in Docker on Windows 10. I pulled the image down: docker pull docker.elastic.co/elasticsearch/elasticsearch:7.10.0 And ran it: docker ...
Joel's user avatar
  • 21
0 votes
1 answer
181 views

How do I run opendistro elasticsearch in docker on HTTP

I'm trying to run the docker image of the AWS opendistro elasticsearch on my laptop for tesing https://opendistro.github.io/for-elasticsearch-docs/docs/install/docker/ When I run it, it expects an ...
Avner's user avatar
  • 143
0 votes
0 answers
5 views

How to avoid Elastic Cloud on Kubernetes memory configuration deadlock?

I'm specifying an Elasticsearch cluster with the elasticsearch.k8s.elastic.co/v1/Elasticsearch from Elastic Cloud on Kubernetes 2.12 CRD like spec: nodeSets: - config: node.store....
Kalle Richter's user avatar
0 votes
1 answer
81 views

Why Elasticsearch is terminated if I bind mount a volume?

In my docker-compose I setup an elasticsearch container: version: "3.3" services: elasticsearch: build: context: . dockerfile: ./dockerfiles/DockerfileElasticSearch ...
Dimitrios Desyllas's user avatar