Hot answers tagged

6

I encountered the same error but with a different issue. The Service port needed a name added to it. https://github.com/istio/istio/issues/19966. And they need to follow the format (protocol-suffix) https://istio.io/docs/ops/deployment/requirements/ ports: - name: https # Use http or https protocol: TCP port: 8080 targetPort: 8080


4

I have resolved the issue by update the gateway manifest. Not sure why the error happen when adding multiple "match". apiVersion: networking.istio.io/v1alpha3 kind: Gateway metadata: name: istio-gateway spec: selector: istio: ingressgateway #default istio ingressgateway servers: - port: number: 80 name: http-istio-gateway ...


2

I'm not sure I understand why listing the public endpoints in the ingress is messy. The common solution is to list the ingress endpoints in the ingress controller. As you mentioned, there are alternatives such as Istio, Consul and other network policy solutions. There's also the Open Policy Agent that can help with this, if you don't want to write YAML.


2

This is most probably there is mismatch of the port that application running in the DOCKER is not the same port exposed in the DOCKER configuration Docker file EXPOSE <PORT> should be same as the port the application is started. Istio Ingress gateway can bind to the container port but can't communicate the application.


2

I am not an expert (yet), but from what I understand, Istio allows you to check that someone (the principle of the call) is already authenticated/authorized. But that actual authentication needs to have been done previously. You can use just about any Identity Provider to get the authentication done. Once done, the JWT from the authentication is added as a ...


1

Restarting Istio controlplane should fix the issue on hand (pods in istio-system, most likely pilot). More importantly do not run Istio 1.2 its very outdated version with many bugs and security issues.


1

Since we are using ISTIO as Ingress Gateway with Kubernetes, the issue is related to ISTIO gateway config. We simply had to replace the matching host to '*' in ISTIO gateway config


1

Changing the destination rule from ISTIO_MUTUAL to SIMPLE fixed this issue. There's obviously a problem with my config with the mTLS.


1

I encountered the same error. The Service port needed a name added to it. https://github.com/istio/istio/issues/19966. Make sure your beta-optimus service port has a name. https://istio.io/docs/ops/deployment/requirements/ ports: - name: https # Use http or https protocol: TCP port: 8080 targetPort: 8080


1

It's true that when you scale your services is possible to have a bottleneck on the monitoring, but for avoiding that you have to check if your monitoring system is pull or push, in case it is push maybe is not the best option but pull is not the right answer for all situations. One of the most used monitoring systems today is prometheus, you can se how it ...


1

Split large virtual services and destination rules into multiple resources: The downside of your kind of configuration is that other configuration (e.g., route rules) for any of the underlying microservices, will need to also be included in this single configuration file. Reference: https://istio.io/docs/ops/best-practices/traffic-management/enter link ...


Only top voted, non community-wiki answers of a minimum length are eligible