3

If you launch the statefulset with the following key set {"spec":{"template":{"spec":{"serviceAccountName":"myserviceaccount"}}}} you can run curl \ https://kubernetes/apis/apps/v1/namespaces/<NAMESPACE>/statefulsets/<STATEFULSET> \ -k -H "Authorization: Bearer $(cat /var/run/secrets/...


2

Define the number of replicas in the values.yaml and pass it anywhere in resources (statefulset) Update 1: You can neither have a dynamic environment variable nor refer to the replicas field in STS. So the only way to get an updated count of STS in each pod is to redeploy with the new value of replicas in values.yaml: replicas: 3 Update 2: According to this ...


1

According the documentation you're giving, you need to remove run-build from the command : $ oc run NAME --image=<image> \ [--generator=<resource>] \ [--port=<port>] \ [--replicas=<replicas>] \ [--dry-run=<bool>] \ [--overrides=<inline_json>] \ [options]


1

Million dollar question - are you running your fluentD as a DaemonSet? If not, there's a chance that fluentd simply isn't running on the node where some containers live. Otherwise, my best guess is, it's missing permissions to read from all namespaces, especially since you mentioned you haven't attached a ServiceAccount to it. If you used a public FluentD ...


1

Just to clarify if I got you right. Do you want to have a separate service for every pod/replica in your statefulSet? If so - this is not how K8s sees services being used. The service is used for grouping and load balancing purposes. In your case, if you want to have 1-on-1 connection between an external client and a pod, I suggest deploying your statefulSet ...


Only top voted, non community-wiki answers of a minimum length are eligible